The 911 Rescue CD

The 911 Rescue CD an introduction

The 911 Rescue CD is a self-contained bootable CD containing an integrated set of programs and scripts designed for the emergency situations when the system doesn't function properly and needs maintenance or when assembling a new PC and no preinstalled operating systems or software is found.

The 911 CD Builder is the tool that automates the creation of the 911 Rescue CD, it walks through the process with its wizard interface while automating most of the steps required to create the 911 Rescue CD, it creates a final ISO file that can be burned with any CD mastering tool (e.g. Nero Burning ROM or CDRecord).

The 911 Disk Builder is a multiple boot disk builder tool, it creates some of the most advanced DOS-based boot disks which uses the ModBoot framework and enables the user to create his own custom modboot disk using an easy wizard-driven interface.

This Help window guides you through the key steps you need to take in creating the 911 Rescue CD.

More detailed information is available from the following sources:

  • The Getting Started Guide, available as an Adobe Acrobat PDF file, downloadable from the 911 CD website.
  • The CD Forum is the official support forum, and the preferred location to post your questions and requests, it can be visited at http://www.911cd.net/forums/.
  • The latest product releases and newest announcements are available from the 911 CD Web site at http://www.911cd.net/.

Copyright © 2002-2004 Ahmad Hisham. All rights reserved.


The 911 CD Builder

The 911 CD Builder Wizard guides you through the steps of creating your own customized compilation of the 911 Rescue CD.

  1. Welcome to the 911 CD Builder
  2. Select the Contents of the CD
  3. Add Windows 2000/XP/2003 Setup (1)
  4. Add Windows 2000/XP/2003 Setup (2)
    • Windows 2K/XP Installation Info
  5. Add Windows 98/98SE/Me Setup
    • Windows 9x Installation Info
  6. Advanced Tools
  7. 911 Utilities / Additional Files
  8. Specify ISO File Options
  9. Ready to create ISO file
  10. Please Wait ... Creating the ISO file
  11. Operation completed successfully


Welcome to the 911 CD Builder

The 911 CD Builder is the tool that automates the creation of the 911 Rescue CD, it walks through the process with its wizard interface while automating most of the steps required to create the 911 Rescue CD, it creates a final ISO file that can be burned with any CD mastering tool (e.g. Nero Burning ROM or CDRecord).


Select the Contents of the CD

In this step you select what will be included in the compilation that will be created at the end of the current session.

  • 911 Boot Disks (911 Software - 911 Net) à The bootdisks that hold the system files that are needed to give the resulting CD compilation the booting capability, and the scripts and programs that are used in the menu that appears (this option cannot be unselected).
    • Use the CDNet Plus disk for Network Access à Use this option to generate the "911 CDNet Plus" bootdisk for network connectivity (this bootdisk connects to Microsoft Windows networks and loads the needed drivers to access the CDROM drive); if this option is unselected the 911 CD Builder generates the default "Network Access" bootdisk (which connects to the Microsoft Windows networks, but can't access the CDROM drive).
    • Accept default list of Network drivers à Unselect this option to make the 911 CD Builder shows a list of available NICs (Network Interface Card) to select the network driver that will be included in the network bootdisk.
      Note: The network drivers will be packaged inside one file with fixed size (2.88 MB), if you select too many drivers the boot disk image creation process may fail.
  • Microsoft Windows 2000/XP/2003 Setup Files à You may choose to include the Setup files of Windows 2000/XP inside the current compilation; if you select this option, a page regarding Windows 2000/XP/2003 Setup will appear in next steps.
  • Microsoft Windows 98/98SE/Me Setup Files à You might also want to include the setup files of the Windows 98/98SE/Me; if you select this option, a page regarding Windows 98/98SE/Me Setup will appear in next steps.
  • Advanced Tools à In the 911 Rescue CD, you may also include the ERD Commander 2002/2003 files, or the O&O BlueCon XXL files for a true all-in-one rescue CD compilation; if you select this option, a page regarding location of these tools will appear in next steps.


Add Windows 2000/XP/2003 Setup (1)

In this step you specify the location of the Windows 2000/XP/2003 installation, you can also specify here the location of the Service Pack file you want to integrate inside your Setup files.

  • Location of Windows Setup Files à The location of the CD root where the Windows Setup resides, or the where the Windows Setup distribution share is located.
    (e.g. If the Windows Setup files are located in C:\XPCD\I386, point the 911 CD Builder to C:\XPCD).
  • Integrate Service Pack à Select wether to integrate a Windows Service Pack in the Windows Setup files or not, this Service Pack will be slipstreamed in the Setup files (when you install from the Setup files in the current compilation, the Service Pack will be pre-installed and can't be uninstalled).
    • Location of Service Pack exe file àThe location of the Service pack EXE file (there is 2 versions of the Service Pack EXE file, the Express and the Network version, you can't use the Express version to slipstream a Windows Setup, you need the Network version, which is usually larger in size).


Add Windows 2000/XP/2003 Setup (2)

In this step you can set more advanced options about automating the Windows Setup that can be launched from the current compilation, you can also customize the Setup to suit your own needs.

  • Customize Installation Info :
    • Store this info in the 911 Win2K Setup Assistant à The information you enter will be stored in the 911 Rescue Software bootdisk, so that when you select to run the 911 Win2K Setup Assistant, the information is already stored in the current compilation, and there is no need to re-enter them again.
    • Store this info in the Windows 2000/XP Installation à The information is stored in the Windows Setup directly, so that if you select to run the Windows Setup from the 911 Boot menu, the information will be used automatically.
    • Set Windows Installation Info... à Opens the "Windows 2K/XP Installation Info" window.
  • Miscellaneous Options :
    • Allow the Installation to accept Corporate Keys à If the Windows Setup files to be included are for the Windows 2000 platform, this option will make the installation continue without asking for the Product Key, and if the Setup files are for the Windows XP/2003 platform it just permits it to accept corporate Product Keys.
    • Remove Extra Languages Files à Select this option to free up around 90 MB of the Windows setup files total size, but select it only if you are not going to install a right-to-left or complex scripts language (like the Arabic or Hebrew languages), or an Asian language (like Traditional Chinese).


Windows 2K/XP Installation Info

Windows 2K/XP/2003 Installation Info

By filling the Windows setup info in this window, you ensure that your compilation includes the necessary information to run the Windows 2K/XP/2003 Setup in the fully automated hands-free mode.

  • Unattended setup script file à Specifies the template file which the unattended setup script will be further edited so that it includes the information entered in this window.
    This greatly increase the customizability of the Unattended Setup mode, as you can create your own setup script using the Windows Setup Manager (can be extracted from Windows 2000/XP CD from \SUPPORT\TOOLS\DEPLOY.CAB).
  • Owner Name à Specifies the end user’s full name.
  • Organization à Specifies an organization’s name.
  • Product Key à Specifies the Product Key (the 25 characters alpha-numeric key) for this particular installation of Windows.
  • Computer Name à Specifies the computer name.
  • Join Workgroup à Selects that the text entered below specifies the name of the peer-to-peer workgroup in which the computer participates.
  • Join Domain à Selects that the text entered below specifies the name of the domain in which the computer participates.


Add Windows 98/98SE/Me Setup

In this step you specify the location of the Windows 98/98SE/Me installation, you can also set more advanced options about automating the Windows Setup that can be launched from the current compilation.

  • Location of Windows Setup Files à The location where the Windows Setup CAB files resides.
    (e.g. If the Windows Setup CAB files are located in C:\98CD\WIN98, point the 911 CD Builder to C:\98CD\WIN98).
  • Customize Installation Info :
    • Store this info in the 911 Setup Assistant à The information you enter will be stored in the 911 Rescue Software bootdisk, so that when you select to run the 911 Setup Assistant, the information is already stored in the current compilation, and there is no need to re-enter them again.
    • Store this info in the Windows Installation à The information is stored in the Windows Setup directly, so that if you select to run the Windows Setup from the command line, the information will be used automatically.
    • Set Windows Installation Info... à Opens the "Windows 9x Installation Info" window.


Windows 9x Installation Info

By filling the Windows setup info in this window, you ensure that your compilation includes the necessary information to run the Windows 98/98SE/Me Setup in the fully automated hands-free mode.

  • Optimized for à Specify the version of Windows the entered Product Key is for.
    (e.g. Windows 98 or Windows 98 SE or Windows Me).
  • Owner Name à Specifies the end user’s full name.
  • Organization à Specifies an organization’s name.
  • Product Key à Specifies the Product Key (the 25 characters alpha-numeric key) for this particular installation of Windows.
  • Computer Name à Specifies the computer name.
  • Workgroup à Specifies the name of the peer-to-peer workgroup in which the computer participates.


Advanced Tools

In this step you specify the location of the ERD Commander 2002/2003 and/or the O&O BlueCon XXL Pro, since these tools need extra processing to integrate correctly to the current compilation, they can't be added directly through the 911_utilities folder.

  • ERD Commander 2002/2003 à Selects wether to include the ERD Commander 2002/2003 or not.
    • Specify the location of your ERD Commander CD à Specifies the location of the CD root where the ERD Commander 2002/2003 files resides.
      (e.g. If the ERD Commander 2002/2003 files are located in C:\ERDCD\I386, point the 911 CD Builder to C:\ERDCD).
  • O&O BlueCon XXL Pro à Selects wether to include the O&O BlueCon XXL Pro or not.
    • Specify the location of your BlueCon CD : à Specifies the location of the CD root where the O&O BlueCon files resides.
      (e.g. If the O&O BlueCon files are located in C:\OOBCON\I386, point the 911 CD Builder to C:\OOBCON).


911 Utilities / Additional Files

In this step you specify the location of the "911 Utilities" folder and the "Additional Files" folder, these folders hold the utilities which will be included and any extra files you want to include in the current compilation.

  • 911 Utilities à Selects wether to include the 911 Utilities folder or not.
    • Location of the 911 Utilities to be used in the CD à Specifies the location of the 911 Utilities folder, this folder holds the utilities which can be used by the 911 Rescue Software Menu and the 911 CD Menu.
      By default it points to the \Program Files\911 CD Builder\911_utilities folder, which contains empty folders with text files describing how to extract the needed executable files for the 911 Menu to use them correctly.
  • Additional Files à Selects wether to include the Additional Files folder or not.
    • Location of the Additional Files to be Added to the CD à Specifies the location of the Additional Files folder, which holds any extra files not directly handled by the 911 CD Builder. By default it points to the \Program Files\911 CD Builder\Additional Files folder, which contains the Windows Autorun program.


Specify ISO File Options

In this step you specify the details of the generated ISO file.

  • ISO File Details :
    • Specify the Location to save the generated ISO file to Specify the name of the ISO file you want to save the current compilation, the generated ISO file can be written to a CD-R/RW using any standard CD recording software.
    • Optimize the ISO file size by encoding duplicate files Select this option to optimize the size of the final ISO file by encoding the duplicate files once in the resulting ISO file.
      Warning: The way of detecting the duplicate files is a lengthy process that takes some time to complete on large folders, in this step the CD Builder doesn't give any indication that it is actively running (the process might take up to 15 minutes on a 700MB source).
    • Clean Session's temporary files after completing Select this option if you don't need the temp files that generated during the 911 Rescue CD ISO file generation.
  • Password Protect the created CD Selects wether to password protection the generated compilation or not.
    Important: The way of saving the password inside the current compilation is considered very dangerous, as it saves the password in clear text (by simply opening the right file, you can read the password directly), so keep the CD in a safe place, and choose a password not used in any other place.
    • Password Type your password here.
    • Confirm Password Retype your password here to make sure they match.

Copyright 2002-2004 Ahmad Hisham. All rights reserved.


Ready to create ISO file

This step summerizes all your selections, and the folders that will be used in the actual creation process, please take some time to review your options and make sure they are all correct.


Please Wait ... Creating the ISO file

This is the step where all the actual work is done, and it takes around 15~30 minutes for a full 700 MB compilation depending on your system configuration.

  • Creating 911 Boot Disks à The step where the bootdisks used in the CD booting are created using the 911 Disk Builder.
  • Inserting Windows 2000/XP/2003 Setup Files à The step where the Windows 2000/XP/2003 Setup files are copied from their source location to the temporary location where the ISO file will be generated from.
  • Inserting Windows 9x Setup Files à The step where the Windows 98/98SE/Me Setup files are copied from their source location to the temporary location where the ISO file will be generated from.
  • Adding 911 Utilities/Advanced Tools à The step where the 911 Utilities/Additional Files/Advanced Tools files are copied from their source location to the temporary location where the ISO file will be generated from.
  • Creating Final ISO File à The final step where the actual ISO file is generated from all the temporary files copied in the previous steps.


Operation completed successfully

At this stage, a fully working compilation of the 911 Rescue CD should be ready for your usage.

The generated compilation is packaged inside one ISO file, this file contains the full contents of the current compilation, in order to use it, you need a software package capable of writing ISO images to CD-R & CD-RW drives.

In our example Nero Burning ROM 6.0 will be used, but you can use any other software capable of burning ISO standard files (such as Roxio Easy CD Creator or CDR-Win).

  1. Open Nero Burning ROM.
  2. Click Cancel on the "New CD compilation" dialog box that appears.
  3. Choose Recorder à Burn Image…
  4. Specify the ISO file location.
  5. Click on Burn.


The 911 Disk Builder

The 911 Disk Builder Wizard guides you through the steps of creating your own customized compilation of any ModBoot-driven bootdisk.

  1. Welcome to The 911 Disk Builder
  2. Select Disk configuration
  3. Select Drivers
  4. Customize the Windows Setup Assistant
  5. Bootdisk Files List
  6. Specify Floppy disk Options
  7. Please Wait ... Creating bootdisk
  8. Operation completed successfully


Welcome to the 911 Disk Builder

The 911 Disk Builder is a multiple boot disk builder tool, it creates some of the most advanced DOS-based boot disks which uses the ModBoot framework and enables the user to create his own custom modboot disk using an easy wizard-driven interface.


Select Disk configuration

In this step you select which bootdisk configuration you need to create, this selection will determine the functionality of the bootdisk and which modules will be included.

  • Available Disk Configurations à Shows the available Disk Configurations to be created, this list can is stored in the files\disklist.ini.


Select Drivers

In this step you select the ASPI & NDIS drivers to be included, if the bootdisk uses the ODI16/ODI32 drivers, the NDIS part will be used for selecting these drivers.

  • Network adapters drivers (NDIS) à The NDIS2 drivers are the driver files that gives the network modules in the bootdisk the ability to use the Network Interface cards (NICs) and operate correctly, you need at least one driver to make the Network module operate correctly.
    • Select which drivers to include... à Opens the "Select Drivers" window, which lists the available drivers to be included in this category of drivers.
  • SCSI Host adapters drivers (ASPI) à The ASPI drivers are used in the ASPI module to let the bootdisk correctly identifies any SCSI Host Adapter found in the system, this will help in recognizing the SCSI CDROM drives, and SCSI hard disks.
    • Select which drivers to include... à Opens the "Select Drivers" window, which lists the available drivers to be included in this category of drivers.


Customize the Windows Setup Assistant

In this step you fill the Windows setup info, this will ensure that your bootdisk includes the necessary information to run the Windows 98/98SE/Me Setup in the fully automated hands-free mode.

  • Optimized for à Specifies the version of Windows the entered Product Key is for.
    (e.g. Windows 98 or Windows 98 SE or Windows Me).
  • Owner Name à Specifies the end user’s full name.
  • Organization à Specifies an organization’s name.
  • Product Key à Specifies the Product Key (the 25 characters alpha-numeric key) for this particular installation of Windows.
  • Computer Name à Specifies the computer name.
  • Workgroup à Specifies the name of the peer-to-peer workgroup in which the computer participates.


Bootdisk Files List

In this step you select the files that will be included in the generated bootdisk, you can select which files to include and which files to exclude.

  • Files list à The list of files to be included in the bootdisk, deselect the files you want to exclude.


Specify Floppy disk Options

In this step you specify the details of the generated bootdisk.

  • How to save your ModBoot Disk :
    • 1.44 MB Floppy Disk à The bootdisk will be directly created inside the floppy disk A:.
    • 1.44 MB Floppy Image à The bootdisk will be created inside a floppy disk image file with the size limitation of the 1.44 MB disk.
    • 2.88 MB Floppy Image à The bootdisk will be created inside a floppy disk image file with the size limitation of the 2.88 MB disk.
  • Destination à Specify the location where the generated bootdisk image will be saved, this option is disabled when the option to use the floppy disk directly is selected.


Please Wait ... Creating bootdisk

This is the step where all the actual work is done, this may take a while if the generated bootdisk is created on a floppy disk, otherwise it shouldn't take more than a minute.

  • Preparing selected Drivers à Prepares the selected drivers to be injected inside the bootdisk.
  • Preparing pre-built drivers cache à Creates the pre-built drivers cache, this cache greatly reduces the time of loading the drivers when the network or ASPI modules uses the drivers.
  • Preparing new floppy image à Gathers all the files in one folder so that it can be injected directly in the floppy image.
  • Copying files to floppy image à Copies the files from the gathering folder to the disk image using bfi utilitiy.


Operation completed successfully

At this stage, a fully working compilation of your desired bootdisk should be ready for your usage.

You have 2 main uses for the generated bootdisk image :

  1. Open it with WinImage to write it to a real floppy disk
  2. Use it with MkISOfs or WinISO to make an ISO image bootable to to generate a new bootable ISO image.


The 911 CD Builder Error Messages

Error Message : There appears to be a problem in your installation, try to manually register redirect.dll

Cause : The required DLL file REDIRECT.DLL is not correctly registered in the System Registry (some of the info required to operate it correctly is missing from the Registry), the 911 CD Builder needs this DLL file to be registered in order to operate correctly.

Fix : Manually register redirect.dll using the REGSVR32 utility.

  1. Click on Start à Run.
  2. Type regsvr32 "C:\Windows\System32\redirect.dll".
  3. Click OK.
  4. Restart the 911 CD Builder.

Error Message : The creation the Boot image BootDiskName failed, operation halted

Cause : The 911 Disk Builder failed to create the needed Bootdisk image, most probably an internal error inside it, or you selected too much drivers to fit inside the bootimage limited size.

Fix : Restart the 911 CD Builder and select fewer drivers when you are prompted to select the drivers.


The 911 Disk Builder Error Messages

Error Message : Your current windows installation doesn't contain the required DOS files needed for the 911 Disk Builder to funtion properly.

Cause : You are using a Windows 2000/XP/2003 system to build the 911 CD, these systems don't contain the DOS files that are needed in order to make the CD bootable, you need a Windows 98/98SE CD to extract these files from its CABs.

Fix : Provide the 911 CD with the location of the Windows 98/98SE CAB files.

Error Message : The file DOSFILE.COM couldn't be extracted successfully.

Cause : There is a problem in the internal extraction engine, it couldn't correctly locate the location of the file that caused the error.

Fix : Use the Import_DOS.cmd batch file to import the DOS files.

  1. Browse to C:\Program Files\911 CD builder.
  2. Double click on the Import_DOS.cmd.
  3. Follow the instructions that appears on the console window.